Sphene Community Tools


Copyright © 2007-2018 by Herbert Poul

You are not logged in.

Change Language:

AddThis Social Bookmark Button

A Django site.

Powered by Sphene Community Tools
Board » General » Captcha testing?

Well I'm trying to get captcha working for anonymous posts. I've installed djaptcha, made sure my font settings are correct, syncdb'd, restarted my server, and I get no captcha on anonymous posting. I'm sure I have PIL installed, and I've even gotten the djaptchatest test package to generate images. However, I have yet to manage to get SCT to produce a captcha. What am I missing? I'm following the (seemingly simple) directions found here.

What I've done:
* Changed the djaptcha/settings.py settings to match my font path.
* Added a font path and size to my SCT project settings.
* Added djaptcha to my INSTALLED_APPS
* Added the djaptcha /captcha URL include to my urlconf.
* Made sure that the sphene community /community URLs are included in my urlconf (should I do both? could this be the problem?)
* Made sure that sphene.community is in my INSTALLED_APPS.
* Run syncdb & restarted my FCGI server.
* Made sure I have no overloaded forum templates.

What am I missing? Where are the captchas supposed to appear?

What? You wanted a sig?
i haven't tested captchas since i renamed permalink to sphpermalink and moved it into the sphutils module ..

i defined sphpermalink at the end of the module, why i tried to access it at the beginning .. so .. it always raised an exception ..

it should now be fixed.. please update from subversion.. if it still does not work please try the following in a ./manage.py shell

import sphene.community.sphutils
sphutils.has_captcha_support() # Should output True

from djaptcha.models import \CaptchaRequest # Should not raise any exceptions :)

--- Last Edited by Herbert Poul at 2007-05-21 19:54:01 ---
Hey, we have Signatures !!! Great, isn't it ? ;)
Well it works now except that the image isn't generated...

Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/django/core/handlers/base.py" in get_response
77. response = callback(request, *callback_args, **callback_kwargs)

TypeError at /community/captcha/1.jpg
captcha_image() got an unexpected keyword argument 'group'
What? You wanted a sig?
Well it works now except that the image isn't generated...
strange.. it seems i've tested it with a different configuration than in the documentation .. :(
i've now added the optional 'group' parameter to the view. please update again, sorry.
Hey, we have Signatures !!! Great, isn't it ? ;)
Ok, is fixed now. Thanks Herbert!
What? You wanted a sig?

Please login to post a reply.

Powered by Sphene Community Tools