Sphene Community Tools


Copyright © 2007-2018 by Herbert Poul

You are not logged in.

Change Language:

AddThis Social Bookmark Button

A Django site.

Powered by Sphene Community Tools
Board » General » Upgrading

Page: Previous 1 2 3 4 Next

this is weird .. where does this LIMIT 1.0 come from *search*
Hey, we have Signatures !!! Great, isn't it ? ;)
can you try to add the following code to your settings.py (if you don't have an SPH_SETTINGS yet, you need to create it SPH_SETTINGS = {})

SPH_SETTINGS['board_post_paging'] = 10

because of any reason it is currently: 10. (no idea why i've added the dot there)

if this isn't working try modifying communitytools/sphenecoll/sphene/sphboard/views.py - and comment out the line 120 (the one setting paginate_by)

sorry for so much bugs :) it seems this one is mysql specific which i haven't tested .. ever .. :( ...
Hey, we have Signatures !!! Great, isn't it ? ;)
this is weird .. where does this LIMIT 1.0 come from *search*
I "greped" all of sphene and couldn't find a LIMIT anywhere. Have you found any clues?
Please disregard the last message. I didn't see your post after the LIMIT 1.0 comment...

SPH_SETTINGS['board_post_paging'] = 10 to my settings, and then tried the post again.

I'm new able to view all the test posts I've made since upgrading. However, my pre-upgrade posts are still not available.

On the forum homepage it says next to each of the forums:
Posts 10, Threads 0

All of them have "Threads 0" except for the forum where I've been making test posts - it has Threads 3. Is there a way to rebuild the threads table?
well .. there was such a method while i developed \ThreadInformation .. i thought it would still be there when running the maintenance script..
but it seems i'm wrong and the method i used to transform my own posts has since vanished..

so i have created a new one :)

try to run this command after updating from subversion:

echo -e "from sphene.sphboard.models import ensure_thread_information\nensure_thread_information()" | ./manage.py shell --plain

--- Last Edited by Herbert Poul at 2007-10-25 19:38:10 ---
Hey, we have Signatures !!! Great, isn't it ? ;)
Seems to be working!!

Thanks so much for all your help!
I just noticed one more bug.

When I click on a thread link under "last post" (far right column forum home page) I get a 404 error. The url pattern is /board/thread/36/?page=0

When I manually remove ?page=0 from the url, the thread loads. So I think there is still something wrong with the permalinks.

What do you think?
it had nothing to do with permalink, but with the 'board_post_paging' setting beeing an integer..
i've fixed that.. try to update from subversion (sphenecoll/sphene/sphboard/models.py) - it should work now...
Hey, we have Signatures !!! Great, isn't it ? ;)
I updated svn to rev 369 - still the same problem...
this is weird ..
can you make sure this change got applied:
-        return int(math.ceil(self.root_post.postCount() / get_sph_setting( 'board_post_paging' )))
+        return int(math.ceil(self.root_post.postCount() / float(get_sph_setting( 'board_post_paging' ))))

- sphenecoll/sphene/sphboard/models.py line 901

you could also try to add a debug output to this function to output the result.. it should be... 1 not 0

it seems to work for me, i'm not sure what could be different for you ..
Hey, we have Signatures !!! Great, isn't it ? ;)

Page: Previous 1 2 3 4 Next

Please login to post a reply.

Powered by Sphene Community Tools